T5000rs help

Discussions about bugs, errors and tech support

T5000rs help

Postby Anestis » Mon Dec 30, 2013 5:01 pm

Hi all

I bought a T500RS 1 month ago to replace my G27, but I have an issue with XMR(all other sims are working fine)
I'll thy to descibe it (my english is little poor).

When i take a right turn the whell is trying to center itself(pulls left) which is good, but when I take a left turn the whell pulls left(wrong way - inverted). With my old g27 everything was working ok.

I unistalled XMR, cleaned the registy, updaded to last version 1.44, tried many options in game about ffb (including "invert" setting) but with no luck.
Is there an option that I have missed? Does anyone using t500rs could share his setting? or t500rs in incompatible with XMR(don't think so, probably I missing something)
My t500 settings are : Overall 50-55, constant 100, periodic 100, spring 0, damper 0, auto center by the game.

Thanks and i'm wishing you all Happy new year
Anestis
 
Posts: 8
Joined: Mon Oct 21, 2013 6:39 pm

Re: T5000rs help

Postby Eugene Cojocar » Mon Dec 30, 2013 5:10 pm

Hi Anestis,

I'm afraid, but I don't have T500RS wheel to test it.
XMR uses standard DX Input calls.
Johnny Walker said something similar about his wheel, but I don't know the model he uses.
http://www.xmotorracing.com/forum/viewtopic.php?f=10&t=369
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: T5000rs help

Postby Anestis » Mon Dec 30, 2013 5:32 pm

Thanks Eugene for quick reply.
Yes I think we have the same problem with Johnny Walker. So I can't do anything right now, hope that somebody with the same wheel will post his settings.
Meanwhile I'll try some settings and if I find something positive will post it here.
Thanks again
Anestis
 
Posts: 8
Joined: Mon Oct 21, 2013 6:39 pm

Re: T5000rs help

Postby Eugene Cojocar » Mon Dec 30, 2013 6:04 pm

You are welcome!

I can only suggest to set the "FFB Friction" (game menu->options->controls->FFB/zones) to zero and play with the FFB settings in the game and wheel.
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: T5000rs help

Postby Anestis » Mon Dec 30, 2013 6:54 pm

FFB friction doesn't change anything about my issue. I forgot to say that "invert" option make the wheel to pull right.Now it's ok with left handed turns. Very strange problem I haven't encountered this in any other game. I can only wait. Thanks
Anestis
 
Posts: 8
Joined: Mon Oct 21, 2013 6:39 pm

Re: T5000rs help

Postby Eugene Cojocar » Mon Dec 30, 2013 7:02 pm

Thanks for the info. I'm trying to solve the issue.
Can you please download and test this sample from the DX SDK?
http://www.exotypos.com/download/xmotorracing/ffconst.zip

Just run it and move the mouse cursor left and right.
You steering wheel must steer left or right accordingly or vice-versa.
Run it as administrator.
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: T5000rs help

Postby Anestis » Mon Dec 30, 2013 7:50 pm

I run it as admin, i even tried with compatibility win 7( I'm under win 8.1 x64) but i get this:
ffconst.JPG
ffconst.JPG (22.7 KiB) Viewed 10709 times
Anestis
 
Posts: 8
Joined: Mon Oct 21, 2013 6:39 pm

Re: T5000rs help

Postby Eugene Cojocar » Mon Dec 30, 2013 8:03 pm

Please download it again. I've upload new version with the dlls.

[url][url]http://www.exotypos.com/download/xmotorracing/ffconst.zip[/url][/url]
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: T5000rs help

Postby Anestis » Mon Dec 30, 2013 8:46 pm

This one works.
When i move the black dot to the left my wheel turns right and black dot to right wheel moves left.
Speed and power depends from how far is black dot from center.
Hope it helps
Anestis
 
Posts: 8
Joined: Mon Oct 21, 2013 6:39 pm

Re: T5000rs help

Postby Eugene Cojocar » Mon Dec 30, 2013 8:50 pm

All right, thanks!
I will upload a special demo build here tomorrow to test it on the t500rs wheel.
If it works I will update all versions.
Be here.
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Next

Return to Tech Support & Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron