Development news

General discussion, news and update announcements

Re: Development news

Postby Kahn62 » Sat Dec 27, 2014 11:56 am

Eugene Cojocar wrote:I'm trying to add auto port forwarding to the XMR Dedi Server to host a server behind NAT. Hope to add it.


Really great idea Eugene. That should help people to serve their own games, which may mean a choice of tracks.
Kahn62
 
Posts: 77
Joined: Fri Nov 23, 2012 10:44 am

Re: Development news

Postby Eugene Cojocar » Sat Dec 27, 2014 12:25 pm

The idea is great, but I can't implement it yet. UPnP doesn't seem to be working. UPnP is a way to forward ports on a NAT router.
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: Development news

Postby Kahn62 » Tue Dec 30, 2014 5:46 am

Eugene Cojocar wrote:The idea is great, but I can't implement it yet. UPnP doesn't seem to be working. UPnP is a way to forward ports on a NAT router.


Eugene, I have an idea about the NAT problem. NAT is a response to the problem that the IPv4 protocol has in being limited to 4,294,967,296 addresses, which with every PC and every networked device we have at the moment is not enough addresses for everyone to have their own unique identifier. In order to get around this the NAT formula was introduced to allow a home network to share an address. Would it be possible to just use the IPv6 protocol, which has 281,474,976,710,656 unique addresses, so that every PC could have it's own IP address, and not need the NAT at all. That way each PC could be addressed via it's own IPv6 address and not have to worry about sharing an IPv4 address. Would you able to use this? IPv6 has been around since Win95, but no-one seems to use it. Maybe there is something I don't know about it that prevents developers from using it?
Kahn62
 
Posts: 77
Joined: Fri Nov 23, 2012 10:44 am

Re: Development news

Postby Eugene Cojocar » Tue Dec 30, 2014 2:11 pm

It's too early to use IPv6. When more than 30-40 percent of devices and ISP use IPv6 then it's time to use IPv6. Most of ISP use IPv4 at the moment.
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: Development news

Postby Eugene Cojocar » Fri Jan 02, 2015 3:53 pm

I want to post this link here as a reference for aerodynamics data. It looks very interesting for me.

http://www.genmay.com/showthread.php?t=827884
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: Development news

Postby Kahn62 » Fri Jan 02, 2015 10:40 pm

I have a problem with the new update Eugene, in that I installed it and had a drive a couple of days ago, but when I started it up today it said I needed to update it again as I have version 1.47, and I need 1.48. I did so, using the 1.48 updater that I used two days ago, and it worked fine again. I then rebooted my PC and it was back to asking for an update again. I repeated this and it worked again, until I rebooted again.
I also noticed that the updated version only recognised one track, Donnington Park, as being there, and six or eight cars. I checked the data/cars and data/tracks folders and both had all of the tracks/cars I would have expected to be there. Should I re-download the 1.48 updater? Do you think this would help?
Kahn62
 
Posts: 77
Joined: Fri Nov 23, 2012 10:44 am

Re: Development news

Postby Kahn62 » Fri Jan 02, 2015 10:46 pm

Eugene Cojocar wrote:I want to post this link here as a reference for aerodynamics data. It looks very interesting for me.

http://www.genmay.com/showthread.php?t=827884


Sounds like a great thing to me Eugene.
Kahn62
 
Posts: 77
Joined: Fri Nov 23, 2012 10:44 am

Re: Development news

Postby Eugene Cojocar » Sat Jan 03, 2015 11:52 am

Kahn62 wrote:I have a problem with the new update Eugene, in that I installed it and had a drive a couple of days ago, but when I started it up today it said I needed to update it again as I have version 1.47, and I need 1.48. I did so, using the 1.48 updater that I used two days ago, and it worked fine again. I then rebooted my PC and it was back to asking for an update again. I repeated this and it worked again, until I rebooted again.
I also noticed that the updated version only recognised one track, Donnington Park, as being there, and six or eight cars. I checked the data/cars and data/tracks folders and both had all of the tracks/cars I would have expected to be there. Should I re-download the 1.48 updater? Do you think this would help?


I will check it today. Thanks for the info.
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

Re: Development news

Postby Kahn62 » Sat Jan 03, 2015 3:25 pm

NP Eugene, thanks for the prompt reply.
Kahn62
 
Posts: 77
Joined: Fri Nov 23, 2012 10:44 am

Re: Development news

Postby Eugene Cojocar » Sat Jan 03, 2015 9:38 pm

I just tested it and found no problem.
Maybe firewall (Intrusion prevention systems) or Antivirus software blocked it. I remember you had similar problem several months ago.
Can you make sure that XMR was updated before re-booting?
fcr64.ptn must contain the string:
Code: Select all
3003427175
XMR Developer
User avatar
Eugene Cojocar
 
Posts: 937
Joined: Thu Oct 18, 2012 2:49 pm

PreviousNext

Return to General

Who is online

Users browsing this forum: No registered users and 2 guests

cron